Revert "Require aclocal 1.11.1 or above for autogen.sh"
authorGuido Trotter <ultrotter@google.com>
Wed, 13 Oct 2010 10:09:45 +0000 (11:09 +0100)
committerGuido Trotter <ultrotter@google.com>
Wed, 13 Oct 2010 10:09:54 +0000 (11:09 +0100)
The comparison is incorrect, and the check also breaks daily work on
autobuilders and older distros.

This reverts commit dbc4dda7f5b66c9905c3cf6e44414536a5b38177.

Signed-off-by: Guido Trotter <ultrotter@google.com>
Reviewed-by: Iustin Pop <iustin@google.com>

autogen.sh

index 0462038..286d0fa 100755 (executable)
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/bin/sh
 
 if test ! -f configure.ac ; then
   echo "You must execute this script from the top level directory."
@@ -9,14 +9,6 @@ set -e
 
 rm -rf config.cache autom4te.cache
 
-ACLOCAL_VERSION=$(${ACLOCAL:-aclocal} --version | head -1 | \
-                 sed -e 's/^[^0-9]*\([0-9\.]*\)$/\1/')
-
-if [[ "$ACLOCAL_VERSION" < "1.11.1" ]]; then
-  echo "aclocal version $ACLOCAL_VERSION is too old (< 1.11.1)"
-  exit 1
-fi
-
 ${ACLOCAL:-aclocal} -I autotools
 ${AUTOCONF:-autoconf}
 ${AUTOMAKE:-automake} --add-missing