Officially require Python 2.6+
authorGuido Trotter <ultrotter@google.com>
Thu, 21 Feb 2013 17:50:55 +0000 (09:50 -0800)
committerGuido Trotter <ultrotter@google.com>
Mon, 25 Feb 2013 18:05:32 +0000 (10:05 -0800)
We have no way to test Python 2.4 compatibility anymore, and that
version is long deprecated. From version 2.8+ require Python 2.6 or
above (but still not 3.0).

Signed-off-by: Guido Trotter <ultrotter@google.com>
Reviewed-by: Michael Hanselmann <hansmi@google.com>

INSTALL
NEWS
configure.ac
devel/upload

diff --git a/INSTALL b/INSTALL
index 636d67b..bff76a7 100644 (file)
--- a/INSTALL
+++ b/INSTALL
@@ -29,24 +29,19 @@ Before installing, please verify that you have the following programs:
 - `iproute2 <http://www.linuxfoundation.org/en/Net:Iproute2>`_
 - `arping <http://www.skbuff.net/iputils/>`_ (part of iputils)
 - `ndisc6 <http://www.remlab.net/ndisc6/>`_ (if using IPv6)
-- `Python <http://www.python.org/>`_, version 2.4 or above, not 3.0
+- `Python <http://www.python.org/>`_, version 2.6 or above, not 3.0
 - `Python OpenSSL bindings <http://pyopenssl.sourceforge.net/>`_
 - `simplejson Python module <http://code.google.com/p/simplejson/>`_
 - `pyparsing Python module <http://pyparsing.wikispaces.com/>`_, version
   1.4.6 or above
 - `pyinotify Python module <https://github.com/seb-m/pyinotify>`_
 - `PycURL Python module <http://pycurl.sourceforge.net/>`_
-- `ctypes Python module
-  <http://starship.python.net/crew/theller/ctypes/>`_, if running on
-  python 2.4 (optional, used for node daemon memory locking)
 - `socat <http://www.dest-unreach.org/socat/>`_, see :ref:`note
   <socat-note>` below
 - `Paramiko <http://www.lag.net/paramiko/>`_, if you want to use
   ``ganeti-listrunner``
 - `affinity Python module <http://pypi.python.org/pypi/affinity/0.1.0>`_,
   optional python package for supporting CPU pinning under KVM
-- `ElementTree Python module <http://effbot.org/zone/element-index.htm>`_,
-  if running on python 2.4 (optional, used by the ``ovfconverter`` tool)
 - `qemu-img <http://qemu.org/>`_, if you want to use ``ovfconverter``
 - `fping <http://fping.sourceforge.net/>`_
 - `Python IP address manipulation library
diff --git a/NEWS b/NEWS
index 65ac4d5..dc9a826 100644 (file)
--- a/NEWS
+++ b/NEWS
@@ -7,6 +7,7 @@ Version 2.8.0 beta1
 
 *(unreleased)*
 
+- The minimum Python version needed to run Ganeti is now 2.6.
 - The :doc:`Remote API <rapi>` daemon now supports a command line flag
   to always require authentication, ``--require-authentication``. It can
   be specified in ``$sysconfdir/default/ganeti``.
index e00771a..c1ac053 100644 (file)
@@ -740,7 +740,7 @@ fi
 AC_SUBST(MAN_HAS_WARNINGS)
 
 # Check for Python
-AM_PATH_PYTHON(2.4)
+AM_PATH_PYTHON(2.6)
 
 AC_PYTHON_MODULE(OpenSSL, t)
 AC_PYTHON_MODULE(simplejson, t)
index 8e6cb67..4293de3 100755 (executable)
@@ -22,7 +22,7 @@
 
 # Usage: upload node-{1,2,3}
 # it will upload the python libraries to
-# $prefix/lib/python2.4/site-packages/ganeti and the command line utils to
+# $prefix/lib/python2.X/dist-packages/ganeti and the command line utils to
 # $prefix/sbin. It needs passwordless root login to the nodes.
 
 set -e -u