Update NEWS file for 2.9.7 release
[ganeti-github.git] / INSTALL
1 Ganeti quick installation guide
2 ===============================
3
4 Please note that a more detailed installation procedure is described in
5 the :doc:`install`. Refer to it if you are setting up Ganeti the first time.
6 This quick installation guide is mainly meant as reference for experienced
7 users. A glossary of terms can be found in the :doc:`glossary`.
8
9
10 Software Requirements
11 ---------------------
12
13 .. highlight:: shell-example
14
15 Before installing, please verify that you have the following programs:
16
17 - `Xen Hypervisor <http://www.xen.org/>`_, version 3.0 or above, if
18   running on Xen
19 - `KVM Hypervisor <http://www.linux-kvm.org>`_, version 72 or above, if
20   running on KVM. In order to use advanced features, such as live
21   migration, virtio, etc, an even newer version is recommended (qemu-kvm
22   versions 0.11.X and above have shown good behavior).
23 - `DRBD <http://www.drbd.org/>`_, kernel module and userspace utils,
24   version 8.0.7 or above; note that Ganeti doesn't yet support version 8.4
25 - `RBD <http://ceph.newdream.net/>`_, kernel modules
26   (``rbd.ko``/``libceph.ko``) and userspace utils (``ceph-common``)
27 - `LVM2 <http://sourceware.org/lvm2/>`_
28 - `OpenSSH <http://www.openssh.com/portable.html>`_
29 - `bridge utilities <http://www.linuxfoundation.org/en/Net:Bridge>`_
30 - `iproute2 <http://www.linuxfoundation.org/en/Net:Iproute2>`_
31 - `arping <http://www.skbuff.net/iputils/>`_ (part of iputils)
32 - `ndisc6 <http://www.remlab.net/ndisc6/>`_ (if using IPv6)
33 - `Python <http://www.python.org/>`_, version 2.6 or above, not 3.0
34 - `Python OpenSSL bindings <http://pyopenssl.sourceforge.net/>`_
35 - `simplejson Python module <http://code.google.com/p/simplejson/>`_
36 - `pyparsing Python module <http://pyparsing.wikispaces.com/>`_, version
37   1.4.6 or above
38 - `pyinotify Python module <https://github.com/seb-m/pyinotify>`_
39 - `PycURL Python module <http://pycurl.sourceforge.net/>`_
40 - `socat <http://www.dest-unreach.org/socat/>`_, see :ref:`note
41   <socat-note>` below
42 - `Paramiko <http://www.lag.net/paramiko/>`_, if you want to use
43   ``ganeti-listrunner``
44 - `affinity Python module <http://pypi.python.org/pypi/affinity/0.1.0>`_,
45   optional python package for supporting CPU pinning under KVM
46 - `qemu-img <http://qemu.org/>`_, if you want to use ``ovfconverter``
47 - `fping <http://fping.sourceforge.net/>`_
48 - `Python IP address manipulation library
49   <http://code.google.com/p/ipaddr-py/>`_
50 - `Bitarray Python library <http://pypi.python.org/pypi/bitarray/>`_
51 - `GNU Make <http://www.gnu.org/software/make/>`_
52
53 These programs are supplied as part of most Linux distributions, so
54 usually they can be installed via the standard package manager. Also
55 many of them will already be installed on a standard machine. On
56 Debian/Ubuntu, you can use this command line to install all required
57 packages, except for RBD, DRBD and Xen::
58
59   $ apt-get install lvm2 ssh bridge-utils iproute iputils-arping make \
60                     ndisc6 python python-openssl openssl \
61                     python-pyparsing python-simplejson python-bitarray \
62                     python-pyinotify python-pycurl python-ipaddr socat fping
63
64 For older distributions (eg. Debian  Squeeze) the package names are
65 different.::
66
67   $ apt-get install lvm2 ssh bridge-utils iproute iputils-arping make \
68                     ndisc6 python python-pyopenssl openssl \
69                     python-pyparsing python-simplejson python-bitarray \
70                     python-pyinotify python-pycurl python-ipaddr socat fping
71
72 If bitarray is missing it can be installed from easy-install::
73
74   $ easy_install bitarray
75
76 Note that this does not install optional packages::
77
78   $ apt-get install python-paramiko python-affinity qemu-img
79
80 If some of the python packages are not available in your system,
81 you can try installing them using ``easy_install`` command.
82 For example::
83
84   $ apt-get install python-setuptools python-dev
85   $ cd / && sudo easy_install \
86             affinity \
87             bitarray \
88             ipaddr
89
90
91 On Fedora to install all required packages except RBD, DRBD and Xen::
92
93   $ yum install openssh openssh-clients bridge-utils iproute ndisc6 make \
94                 pyOpenSSL pyparsing python-simplejson python-inotify \
95                 python-lxm socat fping python-bitarray python-ipaddr
96
97 For optional packages use the command::
98
99   $ yum install python-paramiko python-affinity qemu-img
100
101 If you want to build from source, please see doc/devnotes.rst for more
102 dependencies.
103
104 .. _socat-note:
105 .. note::
106   Ganeti's import/export functionality uses ``socat`` with OpenSSL for
107   transferring data between nodes. By default, OpenSSL 0.9.8 and above
108   employ transparent compression of all data using zlib if supported by
109   both sides of a connection. In cases where a lot of data is
110   transferred, this can lead to an increased CPU usage. Additionally,
111   Ganeti already compresses all data using ``gzip`` where it makes sense
112   (for inter-cluster instance moves).
113
114   To remedey this situation, patches implementing a new ``socat`` option
115   for disabling OpenSSL compression have been contributed and will
116   likely be included in the next feature release. Until then, users or
117   distributions need to apply the patches on their own.
118
119   Ganeti will use the option if it's detected by the ``configure``
120   script; auto-detection can be disabled by explicitly passing
121   ``--enable-socat-compress`` (use the option to disable compression) or
122   ``--disable-socat-compress`` (don't use the option).
123
124   The patches and more information can be found on
125   http://www.dest-unreach.org/socat/contrib/socat-opensslcompress.html.
126
127 Haskell requirements
128 ~~~~~~~~~~~~~~~~~~~~
129
130 Starting with Ganeti 2.7, the Haskell GHC compiler and a few base
131 libraries are required in order to build Ganeti (but not to run and
132 deploy Ganeti on production machines). More specifically:
133
134 - `GHC <http://www.haskell.org/ghc/>`_ version 6.12 or higher
135 - or even better, `The Haskell Platform
136   <http://hackage.haskell.org/platform/>`_ which gives you a simple way
137   to bootstrap Haskell
138 - `json <http://hackage.haskell.org/package/json>`_, a JSON library
139 - `network <http://hackage.haskell.org/package/network>`_, a basic
140   network library
141 - `parallel <http://hackage.haskell.org/package/parallel>`_, a parallel
142   programming library (note: tested with up to version 3.x)
143 - `bytestring <http://hackage.haskell.org/package/bytestring>`_ and
144   `utf8-string <http://hackage.haskell.org/package/utf8-string>`_
145   libraries; these usually come with the GHC compiler
146 - `deepseq <http://hackage.haskell.org/package/deepseq>`_
147 - `curl <http://hackage.haskell.org/package/curl>`_, tested with
148   versions 1.3.4 and above
149 - `hslogger <http://software.complete.org/hslogger>`_, version 1.1 and
150   above (note that Debian Squeeze only has version 1.0.9)
151
152 Some of these are also available as package in Debian/Ubuntu::
153
154   $ apt-get install ghc libghc-json-dev libghc-network-dev \
155                     libghc-parallel-dev libghc-deepseq-dev \
156                     libghc-utf8-string-dev libghc-curl-dev \
157                     libghc-hslogger-dev 
158
159 Or in older versions of these distributions (using GHC 6.x)::
160
161   $ apt-get install ghc6 libghc6-json-dev libghc6-network-dev \
162                     libghc6-parallel-dev libghc6-deepseq-dev \
163                     libghc6-curl-dev
164
165 In Fedora, some of them are available via packages as well::
166
167   $ yum install ghc ghc-json-devel ghc-network-devel \
168                     ghc-parallel-devel ghc-deepseq-devel
169
170 If using a distribution which does not provide them, first install
171 the Haskell platform. You can also install ``cabal`` manually::
172
173   $ apt-get install cabal-install
174   $ cabal update
175
176 Then install the additional libraries (only the ones not available in your
177 distribution packages) via ``cabal``::
178
179   $ cabal install json network parallel utf8-string curl hslogger
180
181 Haskell optional features
182 ~~~~~~~~~~~~~~~~~~~~~~~~~
183
184 Optionally, more functionality can be enabled if your build machine has
185 a few more Haskell libraries enabled: the ``ganeti-confd`` and
186 ``ganeti-luxid`` daemon (``--enable-confd``) and the monitoring daemon
187 (``--enable-mond``). The list of extra dependencies for these is:
188
189 - `Crypto <http://hackage.haskell.org/package/Crypto>`_, tested with
190   version 4.2.4
191 - `text <http://hackage.haskell.org/package/text>`_
192 - `hinotify <http://hackage.haskell.org/package/hinotify>`_, tested with
193   version 0.3.2
194 - `regex-pcre <http://hackage.haskell.org/package/regex-pcre>`_,
195   bindings for the ``pcre`` library
196 - `attoparsec <http://hackage.haskell.org/package/attoparsec>`_
197 - `vector <http://hackage.haskell.org/package/vector>`_
198 - `snap-server` <http://hackage.haskell.org/package/snap-server>`_, version
199   0.8.1 and above.
200 - `process <http://hackage.haskell.org/package/process>`_, version 1.0.1.1 and
201   above
202
203 These libraries are available in Debian Wheezy (but not in Squeeze), so you
204 can use either apt::
205
206   $ apt-get install libghc-crypto-dev libghc-text-dev \
207                     libghc-hinotify-dev libghc-regex-pcre-dev \
208                     libghc-attoparsec-dev libghc-vector-dev \
209                     libghc-snap-server-dev
210
211 or ``cabal``, after installing a required non-Haskell dependency::
212
213   $ apt-get install libpcre3-dev libcurl4-openssl-dev
214   $ cabal install Crypto text hinotify==0.3.2 regex-pcre \
215                   attoparsec vector snap-server
216
217 to install them.
218
219 In case you still use ghc-6.12, note that ``cabal`` would automatically try to
220 install newer versions of some of the libraries snap-server depends on, that
221 cannot be compiled with ghc-6.12, so you have to install snap-server on its
222 own, esplicitly forcing the installation of compatible versions::
223
224   $ cabal install MonadCatchIO-transformers==0.2.2.0 mtl==2.0.1.0 \
225                   hashable==1.1.2.0 case-insensitive==0.3 parsec==3.0.1 \
226                   network==2.3 snap-server==0.8.1
227
228 The most recent Fedora doesn't provide ``crypto``, ``inotify``. So these
229 need to be installed using ``cabal``, if desired. The other packages can
230 be installed via ``yum``::
231
232   $ yum install ghc-hslogger-devel ghc-text-devel \
233                 ghc-regex-pcre-devel
234
235 .. _cabal-note:
236 .. note::
237   If one of the cabal packages fails to install due to unfulfilled
238   dependencies, you can try enabling symlinks in ``~/.cabal/config``.
239
240   Make sure that your ``~/.cabal/bin`` directory (or whatever else
241   is defined as ``bindir``) is in your ``PATH``.
242
243 Installation of the software
244 ----------------------------
245
246 To install, simply run the following command::
247
248   $ ./configure --localstatedir=/var --sysconfdir=/etc && \
249     make && \
250     make install
251
252 This will install the software under ``/usr/local``. You then need to
253 copy ``doc/examples/ganeti.initd`` to ``/etc/init.d/ganeti`` and
254 integrate it into your boot sequence (``chkconfig``, ``update-rc.d``,
255 etc.).
256
257
258 Cluster initialisation
259 ----------------------
260
261 Before initialising the cluster, on each node you need to create the
262 following directories:
263
264 - ``/etc/ganeti``
265 - ``/var/lib/ganeti``
266 - ``/var/log/ganeti``
267 - ``/srv/ganeti``
268 - ``/srv/ganeti/os``
269 - ``/srv/ganeti/export``
270
271 After this, use ``gnt-cluster init``.
272
273 .. vim: set textwidth=72 syntax=rst :
274 .. Local Variables:
275 .. mode: rst
276 .. fill-column: 72
277 .. End: