Merge branch 'stable-2.11' into stable-2.12
[ganeti-github.git] / INSTALL
1 Ganeti quick installation guide
2 ===============================
3
4 Please note that a more detailed installation procedure is described in
5 the :doc:`install`. Refer to it if you are setting up Ganeti the first time.
6 This quick installation guide is mainly meant as reference for experienced
7 users. A glossary of terms can be found in the :doc:`glossary`.
8
9
10 Software Requirements
11 ---------------------
12
13 .. highlight:: shell-example
14
15 Before installing, please verify that you have the following programs:
16
17 - `Xen Hypervisor <http://www.xen.org/>`_, version 3.0 or above, if
18   running on Xen
19 - `KVM Hypervisor <http://www.linux-kvm.org>`_, version 72 or above, if
20   running on KVM. In order to use advanced features, such as live
21   migration, virtio, etc, an even newer version is recommended (qemu-kvm
22   versions 0.11.X and above have shown good behavior).
23 - `DRBD <http://www.drbd.org/>`_, kernel module and userspace utils,
24   version 8.0.7 or above; note that Ganeti doesn't yet support version 8.4
25 - `RBD <http://ceph.newdream.net/>`_, kernel modules
26   (``rbd.ko``/``libceph.ko``) and userspace utils (``ceph-common``)
27 - `LVM2 <http://sourceware.org/lvm2/>`_
28 - `OpenSSH <http://www.openssh.com/portable.html>`_
29 - `bridge utilities <http://www.linuxfoundation.org/en/Net:Bridge>`_
30 - `iproute2 <http://www.linuxfoundation.org/en/Net:Iproute2>`_
31 - `arping <http://www.skbuff.net/iputils/>`_ (part of iputils)
32 - `ndisc6 <http://www.remlab.net/ndisc6/>`_ (if using IPv6)
33 - `Python <http://www.python.org/>`_, version 2.6 or above, not 3.0
34 - `Python OpenSSL bindings <http://pyopenssl.sourceforge.net/>`_
35 - `simplejson Python module <http://code.google.com/p/simplejson/>`_
36 - `pyparsing Python module <http://pyparsing.wikispaces.com/>`_, version
37   1.4.6 or above
38 - `pyinotify Python module <https://github.com/seb-m/pyinotify>`_
39 - `PycURL Python module <http://pycurl.sourceforge.net/>`_
40 - `socat <http://www.dest-unreach.org/socat/>`_, see :ref:`note
41   <socat-note>` below
42 - `Paramiko <http://www.lag.net/paramiko/>`_, if you want to use
43   ``ganeti-listrunner``
44 - `psutil Python module <https://github.com/giampaolo/psutil>`_,
45   optional python package for supporting CPU pinning under KVM
46 - `fdsend Python module <https://gitorious.org/python-fdsend>`_,
47   optional Python package for supporting NIC hotplugging under KVM
48 - `qemu-img <http://qemu.org/>`_, if you want to use ``ovfconverter``
49 - `fping <http://fping.sourceforge.net/>`_
50 - `Python IP address manipulation library
51   <http://code.google.com/p/ipaddr-py/>`_
52 - `Bitarray Python library <http://pypi.python.org/pypi/bitarray/>`_
53 - `GNU Make <http://www.gnu.org/software/make/>`_
54 - `GNU M4 <http://www.gnu.org/software/m4/>`_
55
56 These programs are supplied as part of most Linux distributions, so
57 usually they can be installed via the standard package manager. Also
58 many of them will already be installed on a standard machine. On
59 Debian/Ubuntu, you can use this command line to install all required
60 packages, except for RBD, DRBD and Xen::
61
62   $ apt-get install lvm2 ssh bridge-utils iproute iputils-arping make m4 \
63                     ndisc6 python python-openssl openssl \
64                     python-pyparsing python-simplejson python-bitarray \
65                     python-pyinotify python-pycurl python-ipaddr socat fping
66
67 Note that the previous instructions don't install optional packages.
68 To install the optional package, run the following line.::
69
70   $ apt-get install python-paramiko python-psutil qemu-utils
71
72 If some of the python packages are not available in your system,
73 you can try installing them using ``easy_install`` command.
74 For example::
75
76   $ apt-get install python-setuptools python-dev
77   $ cd / && easy_install \
78             psutil \
79             bitarray \
80             ipaddr
81
82
83 On Fedora to install all required packages except RBD, DRBD and Xen::
84
85   $ yum install openssh openssh-clients bridge-utils iproute ndisc6 make \
86                 pyOpenSSL pyparsing python-simplejson python-inotify \
87                 python-lxm socat fping python-bitarray python-ipaddr
88
89 For optional packages use the command::
90
91   $ yum install python-paramiko python-psutil qemu-img
92
93 If you want to build from source, please see doc/devnotes.rst for more
94 dependencies.
95
96 .. _socat-note:
97 .. note::
98   Ganeti's import/export functionality uses ``socat`` with OpenSSL for
99   transferring data between nodes. By default, OpenSSL 0.9.8 and above
100   employ transparent compression of all data using zlib if supported by
101   both sides of a connection. In cases where a lot of data is
102   transferred, this can lead to an increased CPU usage. Additionally,
103   Ganeti already compresses all data using ``gzip`` where it makes sense
104   (for inter-cluster instance moves).
105
106   To remedey this situation, patches implementing a new ``socat`` option
107   for disabling OpenSSL compression have been contributed and will
108   likely be included in the next feature release. Until then, users or
109   distributions need to apply the patches on their own.
110
111   Ganeti will use the option if it's detected by the ``configure``
112   script; auto-detection can be disabled by explicitly passing
113   ``--enable-socat-compress`` (use the option to disable compression) or
114   ``--disable-socat-compress`` (don't use the option).
115
116   The patches and more information can be found on
117   http://www.dest-unreach.org/socat/contrib/socat-opensslcompress.html.
118
119 Haskell requirements
120 ~~~~~~~~~~~~~~~~~~~~
121
122 Starting with Ganeti 2.7, the Haskell GHC compiler and a few base
123 libraries are required in order to build Ganeti (but not to run and
124 deploy Ganeti on production machines). More specifically:
125
126 - `GHC <http://www.haskell.org/ghc/>`_ version 7 or higher
127 - or even better, `The Haskell Platform
128   <http://hackage.haskell.org/platform/>`_ which gives you a simple way
129   to bootstrap Haskell
130 - `json <http://hackage.haskell.org/package/json>`_, a JSON library
131 - `network <http://hackage.haskell.org/package/network>`_, a basic
132   network library
133 - `parallel <http://hackage.haskell.org/package/parallel>`_, a parallel
134   programming library (note: tested with up to version 3.x)
135 - `bytestring <http://hackage.haskell.org/package/bytestring>`_ and
136   `utf8-string <http://hackage.haskell.org/package/utf8-string>`_
137   libraries; these usually come with the GHC compiler
138 - `text <http://hackage.haskell.org/package/text>`_
139 - `deepseq <http://hackage.haskell.org/package/deepseq>`_,
140   usually comes with the GHC compiler
141 - `curl <http://hackage.haskell.org/package/curl>`_, tested with
142   versions 1.3.4 and above
143 - `hslogger <http://software.complete.org/hslogger>`_, version 1.1 and
144   above.
145 - `hinotify <http://hackage.haskell.org/package/hinotify>`_, tested with
146   version 0.3.2
147 - `Crypto <http://hackage.haskell.org/package/Crypto>`_, tested with
148   version 4.2.4
149 - `regex-pcre <http://hackage.haskell.org/package/regex-pcre>`_,
150   bindings for the ``pcre`` library
151 - `attoparsec <http://hackage.haskell.org/package/attoparsec>`_,
152   version 0.10 and above
153 - `vector <http://hackage.haskell.org/package/vector>`_
154 - `process <http://hackage.haskell.org/package/process>`_, version 1.0.1.1 and
155   above; usually comes with the GHC compiler
156 - `base64-bytestring
157   <http://hackage.haskell.org/package/base64-bytestring>`_,
158   version 1.0.0.0 and above
159 - `lifted-base <http://hackage.haskell.org/package/lifted-base>`_,
160   version 0.1.1 and above.
161 - `lens <http://hackage.haskell.org/package/lens>`_,
162   version 3.0 and above.
163
164 Some of these are also available as package in Debian/Ubuntu::
165
166   $ apt-get install ghc libghc-json-dev libghc-network-dev \
167                     libghc-parallel-dev \
168                     libghc-utf8-string-dev libghc-curl-dev \
169                     libghc-hslogger-dev \
170                     libghc-crypto-dev libghc-text-dev \
171                     libghc-hinotify-dev libghc-regex-pcre-dev \
172                     libpcre3-dev \
173                     libghc-attoparsec-dev libghc-vector-dev \
174                     libghc-zlib-dev
175
176 Debian Jessie also includes recent enough versions of these libraries::
177
178   $ apt-get install libghc-base64-bytestring-dev \
179                     libghc-lens-dev \
180                     libghc-lifted-base-dev
181
182 In Fedora, some of them are available via packages as well::
183
184   $ yum install ghc ghc-json-devel ghc-network-devel \
185                     ghc-parallel-devel ghc-deepseq-devel \
186                     ghc-hslogger-devel ghc-text-devel \
187                     ghc-regex-pcre-devel
188
189 The most recent Fedora doesn't provide ``crypto``, ``inotify``. So these
190 need to be installed using ``cabal``.
191
192 If using a distribution which does not provide these libraries, first
193 install the Haskell platform. You can also install ``cabal`` manually::
194
195   $ apt-get install cabal-install
196   $ cabal update
197
198 Then install the additional native libraries::
199
200   $ apt-get install libpcre3-dev libcurl4-openssl-dev
201
202 And finally the libraries required for building the packages (only the
203 ones not available in your distribution packages) via ``cabal``::
204
205   $ cabal install json network parallel utf8-string curl hslogger \
206                   Crypto text hinotify==0.3.2 regex-pcre \
207                   attoparsec vector base64-bytestring \
208                   lifted-base==0.2.0.3 lens==3.10
209
210 (The specified versions are suitable for Debian Wheezy, for other
211 distributions different versions might be needed.)
212
213 .. _cabal-order-note:
214 .. note::
215   When installing additional libraries using ``cabal``, be sure to first
216   install all the required libraries available in your distribution and
217   only then install the rest using ``cabal``.
218   Otherwise cabal might install different versions of libraries that are
219   available in your distribution, causing conflicts during the
220   compilation.
221   This applies in particular when installing libraries for the optional
222   features.
223
224 Haskell optional features
225 ~~~~~~~~~~~~~~~~~~~~~~~~~
226
227 Optionally, more functionality can be enabled if your build machine has
228 a few more Haskell libraries enabled: the ``ganeti-confd`` daemon
229 (``--enable-confd``), the monitoring daemon (``--enable-monitoring``) and
230 the meta-data daemon (``--enable-metadata``).
231 The extra dependency for these is:
232
233 - `snap-server` <http://hackage.haskell.org/package/snap-server>`_, version
234   0.8.1 and above.
235
236 This library is available in Debian Wheezy or later, so you can use
237 either apt::
238
239   $ apt-get install libghc-snap-server-dev
240
241 or ``cabal``::
242
243   $ cabal install snap-server
244
245 to install it.
246
247 .. _cabal-note:
248 .. note::
249   If one of the cabal packages fails to install due to unfulfilled
250   dependencies, you can try enabling symlinks in ``~/.cabal/config``.
251
252   Make sure that your ``~/.cabal/bin`` directory (or whatever else
253   is defined as ``bindir``) is in your ``PATH``.
254
255 Installation of the software
256 ----------------------------
257
258 To install, simply run the following command::
259
260   $ ./configure --localstatedir=/var --sysconfdir=/etc && \
261     make && \
262     make install
263
264 This will install the software under ``/usr/local``. You then need to
265 copy ``doc/examples/ganeti.initd`` to ``/etc/init.d/ganeti`` and
266 integrate it into your boot sequence (``chkconfig``, ``update-rc.d``,
267 etc.). Also, Ganeti uses symbolic links in the sysconfdir to determine,
268 which of potentially many installed versions currently is used. If these
269 symbolic links should be added by the install as well, add the
270 option ``--enable-symlinks`` to the ``configure`` call.
271
272
273 Cluster initialisation
274 ----------------------
275
276 Before initialising the cluster, on each node you need to create the
277 following directories:
278
279 - ``/etc/ganeti``
280 - ``/var/lib/ganeti``
281 - ``/var/log/ganeti``
282 - ``/srv/ganeti``
283 - ``/srv/ganeti/os``
284 - ``/srv/ganeti/export``
285
286 After this, use ``gnt-cluster init``.
287
288 .. vim: set textwidth=72 syntax=rst :
289 .. Local Variables:
290 .. mode: rst
291 .. fill-column: 72
292 .. End: